Contact: 609.497.7812 | help.desk@ptsem.edu | https://its.ptsem.edu | @ptstechnology

Power Outage on Main Campus
Incident Report for Princeton Theological Seminary
Resolved
The issue has been resolved. Campus internet and all other services are now accessible.
Posted 6 months ago. Sep 15, 2018 - 09:22 EDT
Investigating
It appears that the power outage has affected systems on campus. Currently, getting out to the internet is not possible. We are looking into the issue.
Posted 6 months ago. Sep 15, 2018 - 07:51 EDT
This incident affected: Main Website, Inside.ptsem.edu, Staff/Faculty Email, Student Email, and Formstack.