The emergency upgrades to the PaperCut servers have been successfully completed, and all associated services have been restored.
PaperCut, Web Print (webprinting.ptsem.edu), and campus printing services are now fully available.
Thank you for your patience and understanding while the ITS Help Desk completed this necessary maintenance.
Should you experience any issues with printing or have any questions, please contact the PTS IT Help Desk at help.desk@ptsem.edu or 609-497-7812.
Posted Aug 27, 2026 - 20:45 EDT
Monitoring
The ITS Help Desk has been notified of the need to perform an emergency upgrade to our PaperCut servers.
As a result, PaperCut, Web Print (webprinting.ptsem.edu), and all campus printing services will be temporarily unavailable while the upgrade is being completed.
The maintenance is scheduled for today, August 27, 2026, beginning at 8:00 PM ET. We appreciate your patience and understanding while we complete this necessary upgrade and work to restore printing services as quickly as possible.
Should you have any questions or concerns, please contact the PTS IT Help Desk at help.desk@ptsem.edu or 609-497-7812.
Posted Aug 27, 2026 - 14:18 EDT
This incident affected: Campus Print Services (Web and Mobile Printing - https://webprinting.ptsem.edu, Desktop Printing, Copiers and printers).