Contact: 609.497.7812 | help.desk@ptsem.edu | https://its.ptsem.edu | @ptstechnology

Notice regarding Oxford University Press access issues
Incident Report for Princeton Theological Seminary
Resolved
This incident appears to have been resolved. Thank you for your patience.
Posted Nov 05, 2020 - 08:48 EST
Investigating
We are aware of the issue accessing Oxford University Press content (https://ptsem.libguides.com/az.php?v=66101) and have contacted OUP for assistance. Subscribe or check back here for updates.
Posted Nov 04, 2020 - 10:17 EST
This incident affected: Library Resources (Databases).