Contact: 609.497.7812 | help.desk@ptsem.edu | https://its.ptsem.edu | @ptstechnology

E-Books (Project MUSE)
Incident Report for Princeton Theological Seminary
Resolved
We are considering this resolved. If it would be helpful to you to search the Project MUSE platform directly, please follow the link from the A-Z list: https://ptsem.libguides.com/az.php?a=p&v=66152
Posted Feb 17, 2020 - 16:55 EST
Monitoring
The issue has largely been resolved; the vast majority of the e-book records for which we do not have full text access have been cleared from the library catalog and from Summon. Some related issues are still pending resolution. If it would be helpful to you to search the Project MUSE platform directly, please follow the link from the A-Z list: https://ptsem.libguides.com/az.php?a=p&v=66152
Posted Feb 10, 2020 - 11:06 EST
Update
We are continuing to work to resolve this problem and find that it may take another weekly process to complete. Thank you for your continued patience.
Posted Feb 04, 2020 - 15:55 EST
Identified
Recently, we discovered that many records (with links) in the library catalog and Summon were created for e-books that we do not actually have access to on the Project MUSE platform. Although we've taken the steps needed to fix the problem, the records/links will not disappear until early next week (hopefully by February 3rd or 4th).

Until then, records for e-books that we do not have will continue to come back in Summon and library catalog searches. Apologies for this inconvenience.

We recommend looking for a print copy of the book, if you find that the e-version is not available.
Posted Jan 29, 2020 - 13:46 EST
This incident affected: Library Resources (Library Catalog, Summon).