Contact: 609.497.7812 | help.desk@ptsem.edu | https://its.ptsem.edu | @ptstechnology

Web printing issues
Incident Report for Princeton Theological Seminary
Update
We are continuing to investigate the issues affecting the service with Papercut's support. Web Printing does still support the uploading of Microsoft office documents. We encourage that you utilize this option as your primary method until we have the other issues resolved.
Posted Mar 02, 2022 - 14:55 EST
Investigating
We are currently investigating issues affecting the new campus printing system Papercut. We have had reports of items not recieved by the queue, printing in color, printing pdf and doublesided. We are currently attempting to identify the cause and are working with our software vendor to isolate and resolve the issue. Please let us know at the help desk at help.desk@ptsem.edu or 609-497-7812 so we can notify as things are resolved.
Posted Mar 02, 2022 - 12:59 EST
This incident affects: Mobile Printing and Printers/Scanners/MFP.