Contact: 609.497.7812 | help.desk@ptsem.edu | https://its.ptsem.edu | @ptstechnology

Phone System - Dial Out Issues
Incident Report for Princeton Theological Seminary
Resolved
This incident has been resolved.
Posted 6 months ago. Sep 17, 2018 - 14:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Sep 13, 2018 - 12:46 EDT
Investigating
Dear PTS Community,
We are having issues with dialing phone numbers out side of the Seminary. We are currently investigating this issue and will update you once we have a final resolution.
Thank you for your patience.
Posted 6 months ago. Sep 13, 2018 - 11:12 EDT
This incident affected: Telephone System.